Hi,

I'm wondering if you supported MacOSX or have you planned to support MacOSX?

Thanks and best regards,
Thuc

Hi, I'm wondering if you supported MacOSX or have you planned to support MacOSX? Thanks and best regards, Thuc

blab: Great ! smile
Apart from compiling... do it run? For example the Calculator example? If yes, could you post a picture?

blab: Great ! (blush) Apart from compiling... do it run? For example the Calculator example? If yes, could you post a picture?

I have Xcode 10.1 in a Mojave 10.14.5 machine
The compilation of nana finishes, however there are some errors:

/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib: 
file: libnana_d.a(stdc++.cpp.o) has no symbols
file: libnana_d.a(platform_spec_windows.cpp.o) has no symbols
file: libnana_d.a(bedrock_windows.cpp.o) has no symbols
file: libnana_d.a(frame.cpp.o) has no symbols
file: libnana_d.a(stdc++.cpp.o) has no symbols
file: libnana_d.a(platform_spec_windows.cpp.o) has no symbols
file: libnana_d.a(bedrock_windows.cpp.o) has no symbols
file: libnana_d.a(frame.cpp.o) has no symbols

And when I try to compile a simple example

Undefined symbols for architecture x86_64:
  "_FcConfigAppFontAddFile", referenced from:
      nana::platform_abstraction::font_resource(bool, nana::experimental::filesystem::v1::path const&) in libnana_d.a(platform_abstraction.cpp.o)
...
ld: symbol(s) not found for architecture x86_64

So, I have not been able to test any example.
Any idea?

I have Xcode 10.1 in a Mojave 10.14.5 machine The compilation of nana finishes, however there are some errors: ```` /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib: file: libnana_d.a(stdc++.cpp.o) has no symbols file: libnana_d.a(platform_spec_windows.cpp.o) has no symbols file: libnana_d.a(bedrock_windows.cpp.o) has no symbols file: libnana_d.a(frame.cpp.o) has no symbols file: libnana_d.a(stdc++.cpp.o) has no symbols file: libnana_d.a(platform_spec_windows.cpp.o) has no symbols file: libnana_d.a(bedrock_windows.cpp.o) has no symbols file: libnana_d.a(frame.cpp.o) has no symbols ```` And when I try to compile a simple example ```` Undefined symbols for architecture x86_64: "_FcConfigAppFontAddFile", referenced from: nana::platform_abstraction::font_resource(bool, nana::experimental::filesystem::v1::path const&) in libnana_d.a(platform_abstraction.cpp.o) ... ld: symbol(s) not found for architecture x86_64 ```` So, I have not been able to test any example. Any idea?
edited Jun 6 at 6:02 pm
77
views
6
replies
5
followers
live preview
enter atleast 10 characters
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft